import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/a\\/b\\/c\\/([^\\W_]+)(?:_([0-9]+))?\\/p1=(.*)\\/p2=(.*)\\/p3=(.*)\\/(.*)";
final String string = "/a/b/c/d_9000/p1=<val1>/p2=<val2>/p3=<val3>/<val4>\n"
+ "/a/b/c/d/p1=<val1>/p2=<val2>/p3=<val3>/<val4>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}