import re
regex = re.compile(r"\/a\/b\/c\/([^\W_]+)(?:_([0-9]+))?\/p1=(.*)\/p2=(.*)\/p3=(.*)\/(.*)", flags=re.MULTILINE)
test_str = ("/a/b/c/d_9000/p1=<val1>/p2=<val2>/p3=<val3>/<val4>\n"
"/a/b/c/d/p1=<val1>/p2=<val2>/p3=<val3>/<val4>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")