re = /\/a\/b\/c\/([^\W_]+)(?:_([0-9]+))?\/p1=(.*)\/p2=(.*)\/p3=(.*)\/(.*)/m
str = '/a/b/c/d_9000/p1=<val1>/p2=<val2>/p3=<val3>/<val4>
/a/b/c/d/p1=<val1>/p2=<val2>/p3=<val3>/<val4>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end