using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ?\d\/\d?|\.\d{1,}";
string input = @"1600 1/2 Main St
1600 3/4 Main Street
1600.5 Main St
1600.75 3rd Street";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}