re = / ?\d\/\d?|\.\d{1,}/m
str = '1600 1/2 Main St
1600 3/4 Main Street
1600.5 Main St
1600.75 3rd Street'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end