import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ?\\d\\/\\d?|\\.\\d{1,}";
final String string = "1600 1/2 Main St\n"
+ "1600 3/4 Main Street\n"
+ "1600.5 Main St\n"
+ "1600.75 3rd Street";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}