$re = '/ ?\d\/\d?|\.\d{1,}/m';
$str = '1600 1/2 Main St
1600 3/4 Main Street
1600.5 Main St
1600.75 3rd Street';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);