#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^|(?<=\n))[^:<\n]*[:<](.*)"
Local $sString = "NEWS ID: 918273/1" & @CRLF & _
"TITLE: News Platform Solution Overview (CNN) (US English Session)" & @CRLF & _
"ACCOUNT: supernewsplatformacct (55712)" & @CRLF & _
"" & @CRLF & _
"Your request has been completed." & @CRLF & _
"" & @CRLF & _
"Output Format MP4" & @CRLF & _
"" & @CRLF & _
"Please click on the "Download File" link below to access the download page." & @CRLF & _
"" & @CRLF & _
"Download File <http://news.downloadwebsitefake.com/newsid/file1294757493292848575.mp4>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")