import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=\\n))[^:<\\n]*[:<](.*)";
final String string = "NEWS ID: 918273/1\n"
+ "TITLE: News Platform Solution Overview (CNN) (US English Session)\n"
+ "ACCOUNT: supernewsplatformacct (55712)\n\n"
+ "Your request has been completed.\n\n"
+ "Output Format MP4\n\n"
+ "Please click on the \"Download File\" link below to access the download page.\n\n"
+ "Download File <http://news.downloadwebsitefake.com/newsid/file1294757493292848575.mp4>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}