const regex = /(?:^|(?<=\n))[^:<\n]*[:<](.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|(?<=\\n))[^:<\\n]*[:<](.*)', 'g')
const str = `NEWS ID: 918273/1
TITLE: News Platform Solution Overview (CNN) (US English Session)
ACCOUNT: supernewsplatformacct (55712)
Your request has been completed.
Output Format MP4
Please click on the "Download File" link below to access the download page.
Download File <http://news.downloadwebsitefake.com/newsid/file1294757493292848575.mp4>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}