# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|(?<=\n))[^:<\n]*[:<](.*)"
test_str = ("NEWS ID: 918273/1\n"
"TITLE: News Platform Solution Overview (CNN) (US English Session)\n"
"ACCOUNT: supernewsplatformacct (55712)\n\n"
"Your request has been completed.\n\n"
"Output Format MP4\n\n"
"Please click on the \"Download File\" link below to access the download page.\n\n"
"Download File <http://news.downloadwebsitefake.com/newsid/file1294757493292848575.mp4>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.