#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\*{3}[\w\W]*?\*{3}$"
Local $sString = "Produced by: Emma Dudding, John Bickers, Dagny and David Widger" & @CRLF & _
"" & @CRLF & _
"*** START OF THE PROJECT GUTENBERG EBOOK GRIMMS’ FAIRY TALES ***" & @CRLF & _
"asdfas asdasdfasfd" & @CRLF & _
"body text" & @CRLF & _
"asfa " & @CRLF & _
"*** START OF THE PROJECT GUTENBERG EBOOK GRIMMS’ FAIRY TALES *****"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")