import Foundation
let pattern = #"^\*{3}[\w\W]*?\*{3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Produced by: Emma Dudding, John Bickers, Dagny and David Widger
*** START OF THE PROJECT GUTENBERG EBOOK GRIMMS’ FAIRY TALES ***
asdfas asdasdfasfd
body text
asfa
*** START OF THE PROJECT GUTENBERG EBOOK GRIMMS’ FAIRY TALES *****
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)