# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\*{3}[\w\W]*?\*{3}$"
test_str = ("Produced by: Emma Dudding, John Bickers, Dagny and David Widger\n\n"
"*** START OF THE PROJECT GUTENBERG EBOOK GRIMMS’ FAIRY TALES ***\n"
"asdfas asdasdfasfd\n"
"body text\n"
"asfa \n"
"*** START OF THE PROJECT GUTENBERG EBOOK GRIMMS’ FAIRY TALES *****")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.