#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*:.*\K:.*$"
Local $sString = "52152525121512@gmail.com:161361361:1251136136" & @CRLF & _
"532353472626326@gmail.com:2361251251225:-" & @CRLF & _
"126125252155@gmail.com:215125151251252:135263623,13631535315" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)