use strict;
my $str = '52152525121512@gmail.com:161361361:1251136136
532353472626326@gmail.com:2361251251225:-
126125252155@gmail.com:215125151251252:135263623,13631535315
';
my $regex = qr/^.*:.*\K:.*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";