const regex = /^.*:.*\K:.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*:.*\\K:.*$', 'gm')
const str = `52152525121512@gmail.com:161361361:1251136136
532353472626326@gmail.com:2361251251225:-
126125252155@gmail.com:215125151251252:135263623,13631535315
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);