import Foundation
let pattern = #"^.*:.*\K:.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
52152525121512@gmail.com:161361361:1251136136
532353472626326@gmail.com:2361251251225:-
126125252155@gmail.com:215125151251252:135263623,13631535315
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)