#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\).*?<<(.*?);"
Local $sString = "STDOUT_LOG(logDEBUG4) << "a single line log text" << aVariable;" & @CRLF & _
"" & @CRLF & _
"STDOUT_LOG(logDEBUG4)" & @CRLF & _
" << bsd->sensorName" & @CRLF & _
" << " trainMinValueInWin = " << value.trough" & @CRLF & _
" << " trainMaxValueInWin = " << value.peak" & @CRLF & _
" << " |";" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ", \1);"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)