using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\).*?<<(.*?);";
string substitution = @", \1);";
string input = @"STDOUT_LOG(logDEBUG4) << ""a single line log text"" << aVariable;
STDOUT_LOG(logDEBUG4)
<< bsd->sensorName
<< "" trainMinValueInWin = "" << value.trough
<< "" trainMaxValueInWin = "" << value.peak
<< "" |"";
";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}