re = /\).*?<<(.*?);/
str = 'STDOUT_LOG(logDEBUG4) << "a single line log text" << aVariable;
STDOUT_LOG(logDEBUG4)
<< bsd->sensorName
<< " trainMinValueInWin = " << value.trough
<< " trainMaxValueInWin = " << value.peak
<< " |";
'
subst = ', \\1);'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result