// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\).*?<<(.*?);").unwrap();
let string = "STDOUT_LOG(logDEBUG4) << \"a single line log text\" << aVariable;
STDOUT_LOG(logDEBUG4)
<< bsd->sensorName
<< \" trainMinValueInWin = \" << value.trough
<< \" trainMaxValueInWin = \" << value.peak
<< \" |\";
";
let substitution = ", \\1);";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}