$re = '/\).*?<<(.*?);/s';
$str = 'STDOUT_LOG(logDEBUG4) << "a single line log text" << aVariable;
STDOUT_LOG(logDEBUG4)
<< bsd->sensorName
<< " trainMinValueInWin = " << value.trough
<< " trainMaxValueInWin = " << value.peak
<< " |";
';
$subst = ", \1);";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;