# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((0[1-9]|[1-2][0-9]|3[0-4]|3[6-7]|39|4[0-9]|50)\\d{3})$|^([1-9][0-9]\\d{2}-[0-9]\\d{2})$//gs;t' <<< "
28001"