$re = '/^((0[1-9]|[1-2][0-9]|3[0-4]|3[6-7]|39|4[0-9]|50)\\\\d{3})$|^([1-9][0-9]\\\\d{2}-[0-9]\\\\d{2})$/s';
$str = '
28001';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;