const regex = new RegExp('^((0[1-9]|[1-2][0-9]|3[0-4]|3[6-7]|39|4[0-9]|50)\\\\d{3})$|^([1-9][0-9]\\\\d{2}-[0-9]\\\\d{2})$', 'gs')
const str = `
28001`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);