package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^((0[1-9]|[1-2][0-9]|3[0-4]|3[6-7]|39|4[0-9]|50)\\d{3})$|^([1-9][0-9]\\d{2}-[0-9]\\d{2})$`)
var str = `
28001`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}