import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((0[1-9]|[1-2][0-9]|3[0-4]|3[6-7]|39|4[0-9]|50)\\\\d{3})$|^([1-9][0-9]\\\\d{2}-[0-9]\\\\d{2})$";
final String string = "\n"
+ "28001";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}