package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|\n)\d+\n[\d\:\,\s\->]+`)
var str = `1
00:00:00,000 --> 00:00:16,700
to use 2 languages.
2
00:00:16,700 --> 00:00:19,600
I was saying that we are going to use 2 languages
3
00:00:19,600 --> 00:00:24,700
...I myself will continue to speak because of time`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}