import Foundation
let pattern = #"(?:^|\n)\d+\n[\d\:\,\s\->]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1
00:00:00,000 --> 00:00:16,700
to use 2 languages.
2
00:00:16,700 --> 00:00:19,600
I was saying that we are going to use 2 languages
3
00:00:19,600 --> 00:00:24,700
...I myself will continue to speak because of time
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)