const regex = /(?:^|\n)\d+\n[\d\:\,\s\->]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\n)\\d+\\n[\\d\\:\\,\\s\\->]+', 'g')
const str = `1
00:00:00,000 --> 00:00:16,700
to use 2 languages.
2
00:00:16,700 --> 00:00:19,600
I was saying that we are going to use 2 languages
3
00:00:19,600 --> 00:00:24,700
...I myself will continue to speak because of time`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);