#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w*)(\d(?:\/\d)*)(?:\.)?(\d*)?$"
Local $sString = "GigabitEthernet0/0/0" & @CRLF & _
"GigabitEthernet0/0" & @CRLF & _
"FastEthernet0" & @CRLF & _
"Gi0/0/0" & @CRLF & _
"F0" & @CRLF & _
"GigabitEthernet0/0/0.23" & @CRLF & _
"Gi0/0.1" & @CRLF & _
"F0.101" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")