re = /(\w*)(\d(?:\/\d)*)(?:\.)?(\d*)?$/m
str = 'GigabitEthernet0/0/0
GigabitEthernet0/0
FastEthernet0
Gi0/0/0
F0
GigabitEthernet0/0/0.23
Gi0/0.1
F0.101
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end