$re = '/(\w*)(\d(?:\/\d)*)(?:\.)?(\d*)?$/m';
$str = 'GigabitEthernet0/0/0
GigabitEthernet0/0
FastEthernet0
Gi0/0/0
F0
GigabitEthernet0/0/0.23
Gi0/0.1
F0.101
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);