import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w*)(\\d(?:\\/\\d)*)(?:\\.)?(\\d*)?$";
final String string = "GigabitEthernet0/0/0\n"
+ "GigabitEthernet0/0\n"
+ "FastEthernet0\n"
+ "Gi0/0/0\n"
+ "F0\n"
+ "GigabitEthernet0/0/0.23\n"
+ "Gi0/0.1\n"
+ "F0.101\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}