use strict;
my $str = 'GigabitEthernet0/0/0
GigabitEthernet0/0
FastEthernet0
Gi0/0/0
F0
GigabitEthernet0/0/0.23
Gi0/0.1
F0.101
';
my $regex = qr/(\w*)(\d(?:\/\d)*)(?:\.)?(\d*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}