#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=<%=).*(?=%>)"
Local $sString = "<div>" & @CRLF & _
" <% if ( $_createDiv) { %>" & @CRLF & _
" <div>Div created!</div>" & @CRLF & _
" <% } %>" & @CRLF & _
" <h2>" & @CRLF & _
" <span><%= $_var1 %></span>" & @CRLF & _
" </h2>" & @CRLF & _
" <div><%= markdown.toHTML($_var2 ) %></div>" & @CRLF & _
" <div><%= $_var3 +' more text ' + $_var4 %></div>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")