import re
regex = re.compile(r"(?<=<%=).*(?=%>)", flags=re.MULTILINE)
test_str = ("<div>\n"
" <% if ( $_createDiv) { %>\n"
" <div>Div created!</div>\n"
" <% } %>\n"
" <h2>\n"
" <span><%= $_var1 %></span>\n"
" </h2>\n"
" <div><%= markdown.toHTML($_var2 ) %></div>\n"
" <div><%= $_var3 +' more text ' + $_var4 %></div>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")