re = /(?<=<%=).*(?=%>)/m
str = '<div>
<% if ( $_createDiv) { %>
<div>Div created!</div>
<% } %>
<h2>
<span><%= $_var1 %></span>
</h2>
<div><%= markdown.toHTML($_var2 ) %></div>
<div><%= $_var3 +\' more text \' + $_var4 %></div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end