import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<%=).*(?=%>)";
final String string = "<div>\n"
+ " <% if ( $_createDiv) { %>\n"
+ " <div>Div created!</div>\n"
+ " <% } %>\n"
+ " <h2>\n"
+ " <span><%= $_var1 %></span>\n"
+ " </h2>\n"
+ " <div><%= markdown.toHTML($_var2 ) %></div>\n"
+ " <div><%= $_var3 +' more text ' + $_var4 %></div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}