$re = '/(.)$/';
$str = '+" \\"addressLine1\\": \\"\\",';
$subst = "\1\\n\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;