re = /(.)$/
str = '+" \\"addressLine1\\": \\"\\",'
subst = '\\1\\\\n"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result