// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((2ª|segunda)|(3ª|terça)|(4ª|quarta)|(5ª|quinta)|(6ª|sexta))(-feira)?$").unwrap();
let string = "2ª
3ª
4ª
5ª
6ª
2ª-feira
3ª-feira
4ª-feira
5ª-feira
6ª-feira
segunda
terça
quarta
quinta
sexta
segunda-feira
terça-feira
quarta-feira
quinta-feira
sexta-feira
oitava-feira
segunda-
2ª2ª-feira
-feira
feira
22ª
1ª
7ª
ª
aquartado
sextavado";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}