#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(\\.)|(\*\b(?:(?!\\\*).)*?\b\*)"
Local $sString = "*寫作*用語言 *Hello* 123\\. *asdf*" & @CRLF & _
"\*These* * should * not \*be\* selected. This* neither! *should be. This *neither should\* be* *this should* ffff*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")