re = /(\\.)|(\*\b(?:(?!\\\*).)*?\b\*)/
str = '*寫作*用語言 *Hello* 123\\\\. *asdf*
\\*These* * should * not \\*be\\* selected. This* neither! *should be. This *neither should\\* be* *this should* ffff*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end