$re = '/(\\\\.)|(\*\b(?:(?!\\\\\*).)*?\b\*)/u';
$str = '*寫作*用語言 *Hello* 123\\\\. *asdf*
\\*These* * should * not \\*be\\* selected. This* neither! *should be. This *neither should\\* be* *this should* ffff*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);