using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\.)|(\*\b(?:(?!\\\*).)*?\b\*)";
string input = @"*寫作*用語言 *Hello* 123\\. *asdf*
\*These* * should * not \*be\* selected. This* neither! *should be. This *neither should\* be* *this should* ffff*";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}