import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\.)|(\\*\\b(?:(?!\\\\\\*).)*?\\b\\*)";
final String string = "*寫作*用語言 *Hello* 123\\\\. *asdf*\n"
+ "\\*These* * should * not \\*be\\* selected. This* neither! *should be. This *neither should\\* be* *this should* ffff*";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}