package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\?ab=(\d+)`)
var str = `<li><a href="xyzw.do?ab=1111111111110&method=abcde&maintab=D&_UID_=111Y-T00O-U0‌​0U-PCDE-ZA7C-QQ99-0I00-0550" target="_top"> Letter</a>
<li><a href="xyzw.do?ab=2763276324872&method=abcde&maintab=D&_UID_=111Y-ABCD-EF‌​GH-IHJK-ZA7C-QQ99-0I00-0550" target="_top"> Letter</a> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}