// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\?ab=(\d+)").unwrap();
let string = "<li><a href=\"xyzw.do?ab=1111111111110&method=abcde&maintab=D&_UID_=111Y-T00O-U0‌​0U-PCDE-ZA7C-QQ99-0I00-0550\" target=\"_top\"> Letter</a>
<li><a href=\"xyzw.do?ab=2763276324872&method=abcde&maintab=D&_UID_=111Y-ABCD-EF‌​GH-IHJK-ZA7C-QQ99-0I00-0550\" target=\"_top\"> Letter</a> ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}